Important! Consider This Before Upgrading

To make sure that your upgrade can be successful, check the following warnings and notes; a warning symbol indicates that irreversible damage can be done to your devices.

No downgrade: You cannot restore your IGEL Linux 5 system once you have migrated to IGEL Linux 10. The device storage is overwritten completely with a new partitioning scheme.

Features (e.g. clients): IGEL Linux 10 does not have the complete feature set of IGEL Linux v5. Make sure that the current version of IGEL Linux 10 meets your requirements. For details, refer to the appropriate release notes.

License proxy: Do not upgrade to IGEL Linux 10 if the device is functioning as a license proxy. This functionality is not supported by IGEL Linux 10.

Custom partitions: The contents of custom partitions will be deleted by the upgrade. Make sure to back up the contents and restore them after the upgrade has finished.

Besides becoming dysfunctional after the upgrade, applications and kernel drivers in a custom partition might corrupt the upgrade. For this reason, make sure to first test the upgrade on a characteristic device; see Testing the Upgrade.

We recommend that you disable custom partitions when upgrading; you can enable them once the upgrade has been successfully completed.

Custom commands: The persistence of custom commands cannot be guaranteed.

Besides becoming dysfunctional after the upgrade, custom commands might corrupt the upgrade. For this reason, make sure to first test the upgrade on a characteristic device; see Testing the Upgrade. In general, custom commands must be adapted for IGEL Linux 10.

We recommend that you disable custom commands when upgrading; you can enable them once the upgrade has been successfully completed.

UMD (Universal Multi Display): This functionality is not supported by IGEL Linux 10.

The device will not upgrade if the device is functioning as a UMD master.

Network: All devices must be connected to a WLAN or LAN. LAN is the recommended option.

The device will not be upgraded if connected to PPTP, OpenVPN, NCP, CAG VPN, genucard or LTE.

Hardware support: Make sure that your devices support IGEL Linux 10; please refer to IGEL Devices Supported by Linux.

This document describes upgrading methods for IGEL UD and IGEL IZ devices. Upgrading methods for IGEL UDC are described in a separate document.

License: Each device must have a valid UD license. Find further information about end-of-life (EOL) and maintenance on the IGEL website. If you have any end-of life IGEL IZ devices, contact your IGEL sales representative for a license upgrade.

The device will not be upgraded if the license is not valid.