SSL/TLS Error with Firefox in Appliance Mode

Symptom:

Firefox on IGEL Linux 5.07.100 warns of an SSL/TLS error in appliance mode that does not occur in normal windowing mode. The error code is ssl_error_unsupported_version. This does not happen on IGEL Linux 5.06.x.

Problem:

You cannot connect to the affected HTTPS service.

Solution:

As a workaround you can instruct Firefox to ignore issues with SSL/TLS versions:

  1. In IGEL Setup, go to System > Firmware Customization > Custom Commands > Base Commands
  2. Enter the following command into the After Session Configuration input field:

    echo "clearPref(\"security.tls.version.min\");" >> /services/fbrw/firefox/firefox.cfg

There is also an IGEL Linux private build that addresses this issue.

IGEL's Terms & Conditions apply.